Would like to move to to https://github.com/rug-cit-hpc/pg-playbooks but has large files...
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 

287 lines
5.8 KiB

# Usage: $ ansible-playbook pg-packages.yml
# install all packages
---
- name: install
hosts: compute_node
tasks:
- name: tools
yum:
name:
- ImageMagick
- Lmod
- ORBit2-devel
- alsa-lib-devel
- atop
- attr
- bash-completion
- cowsay
- cvmfs
- cvmfs-config-euclid
- cvmfs-config-none
- dbus-glib-devel
- dos2unix
- elfutils-devel
- emacs
- evolution-data-server-devel
- expect
- finger
- firefox
- ftp
- gawk
- gcc
- gcc-c++
- gd
- gdbm-devel
- gettext-devel
- glibc-devel
- gnome-vfs2-devel
- gstreamer-devel
- gstreamer-plugins-base-devel
- gtk2-devel
- guile-devel
- gvfs-devel
- hdf5-devel
- htop
- hwloc
- hwloc-devel
- infiniband-diags
- infinipath-psm
- iperf
- ipmitool
- irods-icommands
- java-1.6.0-openjdk-devel
- java-1.7.0-openjdk-devel
- java-1.8.0-openjdk
- jobinfo
- kernel-devel
- kernel-headers
- keyutils-libs-devel
- ksh
- lbnl-nhc
- libICE-devel
- libIDL-devel
- libXcomposite-devel
- libXft-devel
- libXmu-devel
- libXp-devel
- libXxf86vm-devel
- libattr-devel
- libcap
- libcap-devel
- libcgroup
- libcgroup-devel
- libcom_err-devel
- libcurl-devel
- libgcc.i686
- libgcrypt-devel
- libgdata-devel
- libgdiplus
- libgeotiff-devel
- libgnomecanvas-devel
- libgnomeui-devel
- libgpg-error-devel
- libgsf-devel
#- libibcm-devel
#- libibumad-devel
- libical-devel
- libjpeg-turbo-devel
- libpng-devel
- libpng12
- librdmacm-devel
- librsvg2-devel
- libstdc++
- libstdc++.i686
- libtasn1-devel
- libwmf-lite
- libxcb-devel
- libxslt-devel
- lua-devel
- make
- mc
- mesa-dri-drivers
- mysql
- mysql-devel
- nano
- nedit
- nspr-devel
- nss-softokn-devel
- nss-softokn-freebl-devel
- ntp
- numactl
- numactl-devel
- opensm
- openssh-ldap
- openssl-devel
- pam-devel
- papi-devel
- parallel
- perftest
- perl
- perl
- perl-CPAN
- perl-DBI
- perl-ExtUtils-CBuilder
- perl-ExtUtils-MakeMaker
- perl-Switch
- perl-Switch
- perl-XML-LibXML
- perl-YAML
- perl-devel
- perl-libxml-perl
- pixman-devel
- plplot-libs
- pmix
- policycoreutils-python
- polkit-devel
- postgresql-devel
- pygobject2-devel
- qperf
- qpid-cpp-server
- qpid-cpp-server-linearstore
- qpid-tools
- readline-devel
- rpm-build
- screen
- sg3_utils
- singularity
- singularity-runtime
- sl
- sqlite-devel
- squashfuse
- systemtap-devel
- tcsh
- telnet
- time
- tk-devel
- traceroute
- unzip
- vim
- xorg-x11-apps
- xorg-x11-proto-devel
- xorg-x11-server-Xvfb
- xorg-x11-xauth
- xterm
- yum-plugin-priorities
- zip
- binutils-devel
- zlib-devel
- bzip2-devel
- atk-devel
- libXext-devel
- libXcursor-devel
- libXinerama-devel
- cairo-devel
- libmng-devel
- pciutils-devel
- mesa-libGLw-devel
- libibmad-devel
- libsepol-devel
- libvirt-java-devel
# - blcr-devel
- opensm-devel
- libicu-devel
- expat-devel
- unixODBC-devel
- openssl-devel
- db4-devel
- libglade2
- libart_lgpl-devel
- nss-util-devel
- popt-devel
- libSM-devel
- pycairo-devel
- GConf2-devel
- gnome-keyring-devel
- libsoup-devel
- check-devel
- libbonoboui-devel
- startup-notification-devel
- gnome-desktop-devel
- libcanberra-devel
- boost-devel
- pulseaudio-libs-devel
- libcap-ng-devel
- freetype-devel
- libXau-devel
- libXrender-devel
- libXrandr-devel
- libXdamage-devel
- pango-devel
- mesa-libGL-devel
- qt-devel
- libXtst-devel
- libselinux-devel
- libstdc++-devel
- libvirt-devel
- proj-devel
- libconfuse-devel
- krb5-devel
- dbus-devel
- elfutils-libelf-devel
- python-devel
- libidn-devel
- libbonobo-devel
- gnutls-devel
- gmp-devel
- nss-devel
- libgnome-devel
- geos-devel
- libnotify-devel
- pygtk2-devel
- tcl-devel
- audit-libs-devel
- fontconfig-devel
- libXt-devel
- libXfixes-devel
- openmotif-devel
- rrdtool-devel
- readline-devel
- libcroco-devel
- libgweather-devel
- libacl-devel
- gdal-devel
- tbb-devel
- glib2-devel
- cyrus-sasl-devel
- libX11-devel
- libXi-devel
- libdrm-devel
- mesa-libGLU-devel
- libxml2-devel
- qt3-devel
- ncurses-devel
- gtk2-devel
- numactl-devel
- ncurses-devel
- irods-dev
- plplot-devel
- libstdc++-devel.i686
- libtar
- lapack-devel
- infinipath-psm-devel
- atlas-devel
- tcl-devel
- tk-devel
- libstdc++-devel
- java-1.8.0-openjdk-devel
- opensm-devel
- libicu-devel
- gnuplot
- yum-utils
- gdb
- bc
- bison
- byacc
- doxygen
- flex
- fuse-devel
- gstreamer-plugins-good
- libaio-devel
- libXaw-devel
- libXpm-devel
- subversion
- subversion-libs
- swig
- perl-PerlIO-gzip
- dialog
state: present